Azure Authentication
Incident Report for True North Cloud
Resolved
Microsoft is still working to fully restore Azure authentication issues. Some services are back online.
Please reference https://status.azure.com/en-us/status for further updates.
Posted Mar 15, 2021 - 20:37 PDT
Identified
Microsoft Azure is experiencing "Authentication errors across multiple Microsoft services."
Please reference https://status.azure.com/en-us/status for details and updates.
Posted Mar 15, 2021 - 14:08 PDT
This incident affected: Azure Overall Availability (Azure Overall Availability).