Azure Services Being Reported as Abnormal
Incident Report for True North Cloud
Resolved
Azure issues seem to have been resolved by Microsoft.
Posted Nov 18, 2021 - 14:20 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2021 - 22:05 PST
Investigating
True North is receiving reports of various Azure and 365 services that are not operating as expected. The Azure Status Page has not been updated by Microsoft yet. Once we receive an update or status page notification from Microsoft, we will update this incident here. You can also reference the Azure Status Page directly by browsing to - https://status.azure.com/en-us/status
Posted Nov 17, 2021 - 13:30 PST
This incident affected: Azure Overall Availability (Azure Overall Availability).